编辑框 内容
Q:编辑框EX1.内容 置文本
关键代码;A2W ()

子程序名 返回值类型 公开 备注
__启动窗口_创建完毕
编辑框EX1.内容 = A2W (“测试文本”)
子程序名 返回值类型 公开 备注
A2W 字节集
 
参数名 类型 参考 可空 数组 备注
Ansi文本 文本型
变量名 类型 静态 数组 备注
len 整数型 单位: Word
Unicode字节集 字节集  
len = MultiByteToWideChar (936, 0, Ansi文本, -1, {  }, 0)
Unicode字节集 = 取空白字节集 (len × 2)
MultiByteToWideChar (936, 0, Ansi文本, -1, Unicode字节集, len × 2)

i本程序使用的支持库列表
ExuiKrnln (未知的支持库)
点击此处复制代码
.版本 2
.支持库 ExuiKrnln

.子程序 __启动窗口_创建完毕

编辑框EX1.内容 = A2W (“测试文本”)

.子程序 A2W, 字节集, 公开
.参数 Ansi文本, 文本型
.局部变量 len, 整数型, , , 单位: Word
.局部变量 Unicode字节集, 字节集

len = MultiByteToWideChar (936, 0, Ansi文本, -1, { }, 0)
Unicode字节集 = 取空白字节集 (len × 2)
MultiByteToWideChar (936, 0, Ansi文本, -1, Unicode字节集, len × 2)