组件 字体
Q:字体怎么用命令设置
关键代码:常量:
FontInfo
PackFont ()

子程序名 返回值类型 公开 备注
__启动窗口_创建完毕
变量名 类型 静态 数组 备注
字体 FontInfo  
字体.名称 = A2W (“微软雅黑”)
字体.大小 = 12
字体.风格 = 1
字体.渲染模式 = 0
字体.渲染参数1 = 0
字体.渲染参数2 = 0
编辑框EX1.字体 = PackFont (字体)

i本程序使用的支持库列表
ExuiKrnln (未知的支持库)
点击此处复制代码
.版本 2
.支持库 ExuiKrnln

.子程序 __启动窗口_创建完毕
.局部变量 字体, FontInfo

字体.名称 = A2W (“微软雅黑”)
字体.大小 = 12
字体.风格 = 1
字体.渲染模式 = 0
字体.渲染参数1 = 0
字体.渲染参数2 = 0
编辑框EX1.字体 = PackFont (字体)

为了方便好调用,可以做成子程序

子程序名 返回值类型 公开 备注
生成字体数据 字节集   //已为您做好调用命令
参数名 类型 参考 可空 数组 备注
字体名称 文本型
字体大小 整数型
字体风格 整数型
绘画模式 整数型
渲染参数1 整数型
渲染参数2 整数型
变量名 类型 静态 数组 备注
打包后的字体 字节集  
FontInfo FontInfo  
FontInfo.名称 = A2W (字体名称)
FontInfo.大小 = 字体大小
FontInfo.风格 = 字体风格
FontInfo.渲染模式 = 绘画模式
FontInfo.渲染参数1 = 渲染参数1
FontInfo.渲染参数2 = 渲染参数2
打包后的字体 = PackFont (FontInfo)
返回 (打包后的字体)
点击此处复制代码
.版本 2

.子程序 生成字体数据, 字节集, , //已为您做好调用命令
.参数 字体名称, 文本型
.参数 字体大小, 整数型
.参数 字体风格, 整数型
.参数 绘画模式, 整数型
.参数 渲染参数1, 整数型
.参数 渲染参数2, 整数型
.局部变量 打包后的字体, 字节集
.局部变量 FontInfo, FontInfo

FontInfo.名称 = A2W (字体名称)
FontInfo.大小 = 字体大小
FontInfo.风格 = 字体风格
FontInfo.渲染模式 = 绘画模式
FontInfo.渲染参数1 = 渲染参数1
FontInfo.渲染参数2 = 渲染参数2
打包后的字体 = PackFont (FontInfo)
返回 (打包后的字体)